h1

Es funktioniert doch: Fonic Stick mit EeePC 701 zum Laufen bringen

14. Dezember, 2008
Bild von paulotavio via www.flickr.com

Bild von paulotavio via http://www.flickr.com

Also, zuerst mal bin ich ja bestürzt darüber, wie lange ich hier in diesem Blog nichts mehr veröffentlicht habe. Nein, das Blog ist nicht tot, es war nur extrem viel los (in beiden meiner Jobs, vor allem aber natürlich drüben bei der readbox, wo wir seit der Buchmesse kein Bein mehr an die Erde bekommen haben).

Heute habe ich aber einen mehr als freudigen Anlass für diesen Blogpost: Nach langem Kampf habe ich es tatsächlich geschafft, meinen neu erworbenen Fonic Stick mit dem Linux-Betriebssystem des Asus EeePC 701 (Xandros) zum Laufen zu bringen. Und weil ich selbst während der letzten Wochen einige Male völlig deprimiert kurz davor stand, das Unternehmen „UMTS/HSDPA mit EeePC“ aufzugeben, möchte ich gerne allen Leidensgenossen (und -genossinnen) meine Erfahrungen und die – am Ende überraschend einfache – Lösung mitteilen.

Vor etwa drei Wochen habe ich mich also des vorweihnachtlichen Konsumdrucks beugen müssen und einen Fonic Stick inkl. UMTS/HSDPA-Tagesflatrate für 2,50 Euro gekauft. Neben verschiedenen Windows-Laptops besitze ich noch einen Asus EeePC 701 8G mit Linux-OS (Xandros) – und ich hatte schon die vage Vermutung, dass das mit der Kompatibilität vielleicht ein Problem sein könnte. Mit dem Stick kommen auch nur Treiber für Windows und MacOS mit, aber ich dachte, in der großen und aktiven Linux-Community werde ich nicht der erste sein, der „ultra-mobil“ sein will und das wirklich schlagende Angebot der Fonic Flatrate mit dem EeePC zu nutzen plant. Entsprechend positiv war ich also auch gestimmt, als eine kurze Recherche über Google und in verschiedenen Foren einige Stimmen zu Tage brachte, die die Funktionsfähigkeit des Sticks (übrigens ein Huawei E160, das war leicht herauszubekommen) bestätigten.

Dass es aber ein solcher Kampf werden sollte (mit einem gleichermaßen glücklichen und einfachen Ende), das hätte ich mir nicht ausmalen können.

Als ich den Stick bekam, probierte ich ihn zunächst unter Windows aus. Es funktionierte einwandfrei, der Stick installiert sich nach Einstecken selbst und die erste Aktivierung und notwendigen Einstellungen lassen sich einfach vornehmen. Man kann da eigentlich nichts falsch machen, alles wird im sich installierenden Verwaltungsprogramm („Mobile Partner“) gemacht.

Dies ist dann auch schon mein erster Tipp:

  1. Den Fonic Stick/Huawei E160 beim ersten Mal auf einem Windows-Rechner installieren, damit man die Grundeinstellungen und die Aktivierung vornehmen kann.

Der Grund ist simpel: Die „Mobile Partner“ Software läuft auf Linux nicht und die Aktivierung z.B. wird per SMS auf die im Stick befindliche SIM-Karte bestätigt. Auf die kann man aber ohne Software nicht zugreifen.

Dann kam der große Moment. EeePC hochgefahren, Stick eingesteckt … und … NICHTS. Also, gar nichts. Außer ein grünes Blinken des Sticks – nichts. Der EeePC schien überhaupt nicht zu bemerken, dass da irgendwas eingesteckt wurde und vom Besitzer eine entsprechende Aktivität des Systems erwartet wurde. Auch die manuelle Einrichtung einer entsprechenden Netzwerkverbindung führte nicht zum Erfolg: Der Stick war einfach für den EeePC nicht sichtbar.

Davon habe ich mich natürlich noch nicht entmutigen lassen und schaute also voller Tatendrang in die verschiedenen Foreneinträge zum Thema. Interessanterweise klaffen die Erfahrungen verschiedener User trotz offensichtlich gleicher Hardware und Systemkonfiguration teilweise eklatant weit auseinander. Während die eine Gruppe anscheinend keinerlei Probleme bei Installation und Betrieb des Sticks hatten, gibt es wieder andere Einträge, die nur unter Zuhilfenahme teils (offensichtlich) tiefer Eingriffe in Systemdateien und Konfigurationen eine Inbetriebnahme versprachen.

Dabei wurde mir allerdings auch schnell bewusst, dass ich vor dem Kauf wohl nicht genau genug hingeschaut hatte. Ansonsten wären mir wohl die vielen Einträge und Kommentare der Ratlosen unter den Usern aufgefallen – vor allem denen, die mit der Befehlszeilenstruktur von Linux nicht so viel anfangen können.

Im Folgenden habe ich über Tage (und Nächte) alles ausprobiert, was ich zum Thema finden konnte, zum Beispiel:

  • die Installation von usb_modeswitch, die aber bei mir nicht einmal erfolgreich war (Stichwort „Gleitkomma-Ausnahme“ … whatever …)
  • Betavine aka. Vodafone-Treiber und Verwaltungssoftware, mit der offensichtlich viele erfolgreich waren. Ich leider nicht – außer dem Splash Screen fand da nach der Installation nichts statt.
  • Einstellungen und Veränderungen in vielen config-Dateien (mit einer Variante des alten Norton Commanders, der in Linux weiterlebt – dort nur anders heißt … warum genau stehen die Leute auf Linux und verteufeln Betriebssysteme, bei denen man Einstellungen und Verwaltungsaufgaben per grafischer Oberfläche vornehmen kann?)
  • Booten des Systems mit oder ohne vorher eingesteckten Stick (etwa 1.000 mal)
  • Installation und Deinstallation des Asus-eigenen GSM/UMTS Modemtools (auch das hat nix gebracht)
  • vier mal Rücksetzen auf die Werkseinstellungen
  • zig andere Tools, deren Namen ich inzwischen alle wieder vergessen habe

Ich war, wie bereits erwähnt, mehrfach an dem Punkt wo ich (a) den Stick zurückschicken, (b) Windows auf dem EeePC installieren oder (c) mir gleich ein neues Windows Netbook kaufen wollte. Und dann hat mich gestern noch einmal der Ehrgeiz gepackt.

Und gegen 2.30h heute morgen war’s soweit. Bei einer erneuten Tour durch verschiedene Suchmaschinen-Anfragen und Forenbeiträge stieß ich auf einen englischen Beitrag (Link hab ich leider nicht mehr), der mich auf die richtige Spur brachte:

Dieser User berichtete nämlich davon, dass ihm aufgefallen war, dass der Stick durchaus richtig erkannt wurde, allerdings in den Einstellungen der Default-LAN-Verbindung. Und das ist der Schlüssel zum Erfolg. Hier also Schritt für Schritt:

  • Zunächst: Alle Änderungen habe ich im Easy Mode gemacht (nicht Advanced oder Full Desktop)
  • Über den Synaptic Package Manager habe ich dann ein Update durchgeführt (Schaltfläche „Aktualisierungen vormerken“, dann „anwenden“)
  • In die Netzwerkverbindungen, dort LAN-Verbindung auswählen (man kann dort mal nachsehen, ob der Stick dort wirklich erkannt wird, wie oben beschrieben)
  • Die LAN-Verbindung löschen
  • Eine evtl. aktivierte WLAN-Verbindung deaktivieren (muss vielleicht gar nicht sein, hab’s trotzdem mal gemacht)
  • System herunterfahren, Stick einstecken (es ist tatsächlich wichtig, dass der Stick beim Booten schon eingesteckt ist), System hochfahren
  • Netzwerkverbindungen öffnen, eine neue UMTS/HSDPA-Verbindung hinzufügen
  • Voilà – der Stick wird erkannt und kann dort eingerichtet werden
  • Zu den Einstellungen: Diese sind bei Fonic zu finden (APN = „pinternet.interkom.de“, User =“-„, Passwort = „-„)
  • PIN eingeben (der Stick sollte dann blau blinken, d.h. er ist ins Netz eingebucht)
  • Einrichtung fertigstellen
  • Netzwerkverbindung aktivieren. Jetzt sollte es gehen.

Ich bin jedenfalls extrem erleichtert, dass es jetzt dooch so funktioniert, wie ich mir das vorgestellt hatte: Kleiner Computer, unabhängig von WLAN ins Netz. Super.

Hoffe, die Anleitung hift. Viel Glück!

Advertisements

3 Kommentare

  1. -genau dasselbe Problem habe ich auch,mich wundert auch die merkwürde LAN-Verbindung,die selbst startet

    mal probieren,ob das löschen der merkw.LAN-Verbindung hilft


  2. habe dieselben Probleme, bei mir läuft der E160 im Full-Desktop Modus nach vielen Probieren vom Netzwerkprogramm(der E160 wurde mal erkannt und ich habe eine Verbindung mit einer Congstar-SIM eingerichtet D1,volumenbasiert),wenn es einmal läuft,bleibt es stabil

    gruss frank027


  3. hatte hier auch die Probleme (eeepc 4g surf, xandros-linux, 512MB). Update mit Synaptic lief gut, der Stick wurde erkannt und eine LAN-Verbindung mit ihm eingerichtet. Löschen, WLAN ausschalten, Neustart mit eingestecktem Stick – und eine UMTS-Verbindung ließ sich einrichten. Stick wurde NICHT über Windows aktiviert! Beim Einrichten mit den Nutzerdaten konnte man schon die Geduld verlieren – braucht eben „etwas“ länger, das Gerät. Die ersten 2,50 Euro sind versurft!



Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s

%d Bloggern gefällt das: